Saturday, February 9, 2013

WTF is wrong with my home PC?


The home PC has been driving my wife and me nuts for a long time.  It runs everything, and since I have replaced the power supply and installed an extra fan on the video card, it does not crash any more.  But the memory usage over the course a day (after a reboot) goes from just under 2GB to 6GB (the amount of physical memory I have).

A wee bit of background: HP Pavilion (bought August 2009), Intel i7 (8-core) processor, Windows 7 Home Premium (upgraded from Vista when 7 became available, approximately 5 months later).  6GB of memory (as I said), three internal disks (system disk is 0.6TB; photos is 1TB and videos is also 1TB).


If we use the PC normally for several hours (which is how the day usually evolves) and then go away for a while (e.g., a good night's sleep), when we come back it takes for-EVER to come alive.  For example, I'll jiggle the mouse, the screen will come alive and I look at the screen.  The internal clock say a time that is about an hour after we stopped using the computer.  After about ten seconds, the clock changes to the correct time, and MS Outlook pops up all the emails that have arrived over night (a little pop-up indicator associated with the Outlook icon in the System tray).

I use Adobe Lightroom a lot now--it is a well-deserved memory hog [loading and interpreting dozens of 25MB images].  When I start LR immediately after startup, it works fine.  But when I try to use it at the end of the day, it takes for-EVER to do anything.

My wife tends to use Chrome for everything.  On a normal day, she'll have a dozen or two tabs open.  She likes it a lot.

The Task Manager has some interesting things to say.  First (and foremost): the CPU is almost completely idle.  The other very interesting aspect is that when I sum the memory usage of all the processes running for all users, it is nowhere near the amount that the Task Manager says the system is using: like 2GB in the sum of all the processes, but 6GB total memory used (in the summary box).


I have figured out a few things to measure.  First, as indicated above, rebooting the system resets the memory usage to a normal level for a while.

This morning, I closed all programs and watched the task manager for a while.  I forced several background processes to close: Amazon Sound Cloud, DropBox, Chrome, a couple of ready-to-launch things (e.g., my Garmin GPS watch has one, as does the Logitech camera and a Logitech steering wheel that Son #3 uses), CrashPlan.  The odd part of this operation is that there were about 7 instances of Chrome left long after I had closed it.

Then I logged off my wife and logged into Windows 7 as me (we have two such accounts already setup).  I did a few simple things (checked a web page in Chrome and then exited Chrome), changed my background (to show a series of pictures of my lovely granddaughter), and then watched the Pebble Beach golf tournament.   At the end of this (ahem!) 2 hour experiment, the memory usage had stayed at 0.9GB the whole time!


Then I logged off and logged back in as my wife.  She has several things that run automatically (e.g., Sound Cloud), so the initial memory usage was 1.8GB.  I did some work on Lightroom (it was great and snappy!).  I closed LR and I went away for a while (I watched "Looper"--great movie, if you can get through the violence and gore of the first 110 minutes of it and see the last 5).  When I returned, the memory usage had not increased!


Working Assumption

There is something we run normally that has a memory leak.  My current guess: Chrome.

How do I test this theory?

Here are the ways I can image testing this theory:

  • Uninstall Chrome and re-install it.
    • If this works, it would indicate to me that some sort of stupid-ware has been picked up by this installation of Chrome.
  • Uninstall Chrome and install Firefox.
  • Any other ideas?????
So, that's it for now.  The working assumption is that Chrome is Evil on our home PC.

Update: 2/10/13

The PC ran overnight with nothing in the foreground.  It was using 5.5 GB.  Oops!  I killed a couple of background processes (Amazon Sound Cloud) and the memory allocation went to 4.7 GB.  There is something else wrong besides by "Chrome" assumption.

A Facebook friend (Todd R.) pointed me to the following interesting web sites:


  1. IE seemed to do the same for me - it would just keep spawning processes. Mine has gotten a lot better, but it may be due to getting a newer version of IE. Since it is easy to do, I would uninstall Chrome for a while and go to Firefox and see if that works better. It seems that you would know in a day or two. Really, my level of expertise is no different than yours.

  2. The problem was a flakey system disk. I did a disk check (which required a reboot, of course) and everything is hunkey dorey!


    Moral: Do a disk check every month or so.

    Another moral: Get a good backup scheme.